Sold: Final Expansion 3 Rev 11 [2nd Batch]

Vic 20 Item Exchange

Moderator: Moderators

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 1:30 pm

From that archive, only copy the contents of the SD folder to the root of your SD card. As mrr19121970 says, the LOADER has to be in the root directory. Also make sure your card is not formatted NTFS.

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 2:05 pm

Yes, I put the loader at the root but it still does not work

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 2:48 pm

Then there has to be a problem with the SD card. I tested your cartridge, including the Disk Loader, before sending it. What size is the SD card? What filesystem is it using?

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 3:27 pm

It is a 2MB SD Card. It is using the FAT file system. I also have an SD2IEC drive with a 2gb card. I attempted using that also but no luck.

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 3:36 pm

Try formatting the card FAT32 then extract the contents of the SDCard folder into the root of your SD card. The root folder should only have the carts folder and loader file. If that doesn't work then you could try copying the contents of the SDCard\carts\a-c folder to the root of the SD card to see if it works. If not, I'm out of ideas. :(

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 4:30 pm

No luck. I tried Fat32 with loader file at root and no luck. I reformatted back to Fat with loader file and still no luck. The screen just flashes quickly but nothing else happens.

Just to clarify, when you mean root folder, your saying to drop the loader file directly onto the SD card itself? If that's the correct, that's what I did. I put it directly on the card, all by itself, outside of the carts folder.

Note: I notice on the cartridge board there are a series of jumpers. Do any of those jumpers need to be bridged? In addition, there are 4 switches that are in the following position (1-off, 2-off, 3-on, 4-on). Also, do I need to install the battery. Pretty sure it isn't necessary, but I am getting desperate at this point.

Also a few posts back you mention that it could be the card having a problem. I have 3 cards and all of them give me the same results :( .

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 5:15 pm

Yes, the root is the SD card itself.

The exposed pins are not jumpers. They are disk change buttons and other connections to the ATmega. DO NOT put jumpers on them. The switch positions are correct. The battery is only needed for the real time clock to keep time when the computer is turned off.

When you turn on the VIC-20, press F7 to go to basic. Type $ then press enter. Do you see the directory? What do the lights on the FE3 do when you turn on the computer?

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 5:23 pm

Ok I tried what you suggested. I turned on computer, pressed F7 and enter into CBM Basic screen. From there, I pressed $ and enter and I get nothing at all. I don't see any directories. I look at the led's when I press it and they don't light up at all.

When I turn the Vic on, here is what the led's do. They both come on for a very brief moment, the green instantly goes out, followed by the red going out. After the red goes out, the green again flashes for an instant.
Last edited by Barney on Fri Feb 24, 2017 5:28 pm, edited 1 time in total.

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 5:24 pm

Umm... Silly question... Do you have a disk drive cable plugged in from the disk drive port on the VIC-20 to the FE3? If so, try another cable.

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 5:30 pm

Wait a second, you may have just found the problem. I don't have a cable plugged in at all. In fact, I don't even own one. Is this the entire cause of this issue?

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 5:33 pm

That's it! :)

The cartridge is self contained and the Cart Loader loads directly off the EEPROM. However, all the SD card access is done through the FE3's disk drive connection. You just need an IEC cable to make it work. You can get one from Retro Innovations.

http://store.go4retro.com/commodore-iec ... ive-cable/

Sorry about that. I don't sell them with cables because most people already have a floppy drive with a cable.

Let me know if I can be of more assistance. :D

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 5:38 pm

YeeeeHaaaw......we're in business baby. Thanks everyone for helping me out. it's working good.

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 5:39 pm

Did you find a cable?

Heather

User avatar
Barney
Vic 20 Devotee
Posts: 278
Joined: Wed Feb 08, 2006 7:02 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby Barney » Fri Feb 24, 2017 5:41 pm

Yes, I looked through all my junk and found one.

User avatar
SkydivinGirl
Vic 20 Enthusiast
Posts: 191
Joined: Thu Jan 28, 2010 9:19 am

Re: Pre-Orders: Final Expansion 3 Rev 11 [2nd Batch]

Postby SkydivinGirl » Fri Feb 24, 2017 5:44 pm

Wonderful! I'm so glad everything is working properly. I'd suggest picking up at least one of the 12" cables on the Retro Innovations site. They are a great length for going from the VIC-20 to the FE3. They are also brand new, recently made cables.

I really hope you enjoy the FE3. It's really my favorite cart for the VIC-20. You should read the user manual as well to familiarize yourself with the cartridge. Parts of the manual are difficult to understand but we'll be working on an updated one.

http://jvaltane.kapsi.fi/vic20/fe/VIC-20%20Final%20Expansion%20User%20Manual.pdf

Heather


Return to “Buy, Sell, and Trade”

Who is online

Users browsing this forum: No registered users and 1 guest