VIC 1112 IEEE Interface

Vic 20 Item Exchange

Moderator: Moderators

User avatar
Kakemoms
Vic 20 Afficionado
Posts: 401
Joined: Sun Feb 15, 2015 8:45 am

Re: VIC 1112 IEEE Interface

Postby Kakemoms » Sat Dec 17, 2016 4:08 pm

eslapion wrote:It's the opposite.

The MOS6522 IRQB can only drive low or do nothing at all. The 65C22 or R65C22 can drive low or high. This way you can connect more than one 6522 to the same IRQ line and this is done in many pieces of equipment. If a 6522 pulls low and a R65C22 pulls high then you have a tug of war between the two.

A diode may do the job but it has to be extremely fast and have a very low voltage drop. The 1N6263 I use on the Behr-Bonz DRL 'AND' gate should to the job.

A 10kOhms pull-up resistor will definitely not.


Thanks Eslapion. I didn't have that diode, but I managed to get it to work with a 1N5814:

IMG_5063.JPG


At least the R65C22 works for my Vic-20 and its keyboard. Unfortunately it didn't work for the IEEE device. I got the same problems as with the MOS 6522. E.g. "Load"$",9" loads the directory but displays nothing (unlike the original Vic-1112 which shows it):

IMG_5065.JPG


I will test more another day. Maybe there is a strange bug in the software or something about the R65C22 in this configuration.

User avatar
Kakemoms
Vic 20 Afficionado
Posts: 401
Joined: Sun Feb 15, 2015 8:45 am

Re: VIC 1112 IEEE Interface

Postby Kakemoms » Sun Dec 18, 2016 8:56 am

Short update: I moved the two MOS6522 from my Vic-20 into the IEEE interface and I get the same result. With two R65C22 in the Vic-20 (with the IRQ diode modification) I have keyboard and serial read/write (towards my Commodore 1541) working as before.

The program starts as usual (with SYS45065) and the EPROM verifies as being the same as the image you released. I will burn a new EPROM (with the original VIC-1112 image) and test if it works with that one.

dragos
Vic 20 Afficionado
Posts: 454
Joined: Mon Nov 21, 2005 6:41 pm

Re: VIC 1112 IEEE Interface

Postby dragos » Tue Dec 20, 2016 2:16 am

Please keep me informed of your progress. I suggest trying real mos 6522s, maybe you have a 1541 lying around you can borrow them from.

I test each board thoroughly prior to shipment (read/write and burn in) and this is the first issue not related to user soldering error I have had.

very curios to put the issue to bed and see you have a working card.

Thanks!
0110 0110 0110 The number of the beast...

User avatar
orion70
Meteo VIC
Posts: 3204
Joined: Thu Feb 02, 2006 4:45 am
Location: Piacenza, Italy
Occupation: Biologist

Re: VIC 1112 IEEE Interface

Postby orion70 » Tue Jan 17, 2017 2:23 pm

Any news about the ETA for this interface? It's been a while since the Kickstarter campaign was closed...

User avatar
Kakemoms
Vic 20 Afficionado
Posts: 401
Joined: Sun Feb 15, 2015 8:45 am

Re: VIC 1112 IEEE Interface

Postby Kakemoms » Tue Apr 18, 2017 2:15 pm

Just to follow up on this; I have just tested the cart with an original Vic-1112 ROM image. The SYS45065 starts the software, but I can not LOAD, format (PRINT#15,"NO:...) or SAVE to the disk. The original Vic-1112 cart works with this drive and can do all that, so there is something wrong with the cart.

I will try to re-flow the solder in case its just a poor connection. I am also a little unsure about some of the via holes as they do not seem to contain metal (or maybe they don't have the solder mask opened). It could of course also be one of the IC's, but I don't have any of these (except for the 74LS00N) here, so I can't check that easily.


Return to “Buy, Sell, and Trade”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest