Can't start Vic cartridges from VICE xvic command line

You need an actual VIC.

Moderator: Moderators

Vic 20 Amateur
Posts: 43
Joined: Sun Jun 07, 2015 5:57 pm
Location: Oz

Can't start Vic cartridges from VICE xvic command line

Postby Neo-Rio » Wed Mar 15, 2017 7:28 pm

I was mucking about with RetroPie trying to get CRT vic-20 cart games to start from the command line, but I keep hitting an error.
Then I tried it in Windows.... same problem

Note that I'm using Vice-3.0 on both.

xvic.exe -cartgeneric "<path to crt>"

I get : Argument "<path to crt>" not valid for option -cartgeneric

If the path isn't valid as an option, I clearly don't know what is.
I've been using CRT files from the vic-20 TOSEC that you can find on
I tried cosmic cruncher as a test, but it seems no matter what I put that path to the file in, it doesn't work.

Also tried running xvic.exe "<path to crt>" without the -cartgeneric but the emulator thinks it's a program file, drops it into an autostart.d64 and of course won't start either.

I have zero problems loading the CRT and getting it to work if I just do it through the xvic GUI and select a generic CRT. However I'm trying to get xvic to autostart with the cartridge.

Return to “Emulation and Cross Development”

Who is online

Users browsing this forum: No registered users and 2 guests