Sick Vic

Modding and Technical Issues

Moderator: Moderators

User avatar
SparkyNZ
Vic 20 Dabbler
Posts: 96
Joined: Tue Jan 18, 2011 2:23 am

Sick Vic

Postby SparkyNZ » Thu Dec 21, 2017 12:57 pm

I just powered up my Vic after being in the cupboard for a while. I got this upon startup.. :-(

Image

The cursor is blinking and can be moved around the screen with the cursor keys. Typing letters or trying to change the cursor colour has no effect.

Any idea what could be wrong with this?

My thinking is that the Vic chip itself may be OK since we have a 'screen', border and a flashing cursor. I did mod this Vic to give it 16k RAM by piggy-backing RAM on top of the ROM chips. Could dry joints to either ROM chips cause this?

User avatar
SparkyNZ
Vic 20 Dabbler
Posts: 96
Joined: Tue Jan 18, 2011 2:23 am

Re: Sick Vic

Postby SparkyNZ » Thu Dec 21, 2017 2:52 pm

I've just tried swapping out both Basic and Char ROMs with another Vic - same problem.

Just read:

UC2 74LS04 LOGIC
Screen character colors incorrect (scrambled). If very bad, entire
screen becomes garbled with flashing characters, vertical bars and
random colors.

Wondering if I should just try replacing this chip and see what gives?

norm8332
Vic 20 Devotee
Posts: 291
Joined: Sun Nov 13, 2016 11:04 am
Location: USA

Re: Sick Vic

Postby norm8332 » Thu Dec 21, 2017 6:20 pm

I'd try that, hopefully it's not the VIC, those are hard to find/ or at a decent price.

User avatar
SparkyNZ
Vic 20 Dabbler
Posts: 96
Joined: Tue Jan 18, 2011 2:23 am

Re: Sick Vic

Postby SparkyNZ » Thu Dec 21, 2017 9:00 pm

norm8332 wrote:I'd try that, hopefully it's not the VIC, those are hard to find/ or at a decent price.


Yeah I was tempted to desolder a 7404 from another one of my Vics but I could damage one of them in doing so.. so I've ordered some new chips and I'll give that a try in a few weeks.. unless I can find one lying around somewhere.


Return to “Hardware and Tech”

Who is online

Users browsing this forum: No registered users and 1 guest