Early Vic-20 Pet style keyboard problem

Discuss anything related to the VIC

Moderator: Moderators

victim
Vic 20 Newbie
Posts: 2
Joined: Fri Aug 11, 2017 7:20 am
Location: UK

Early Vic-20 Pet style keyboard problem

Postby victim » Sun Aug 13, 2017 1:47 pm

Hi all, I have a early Vic in very good condition apart from the pet style keyboard. it will only type characters on every other key on the two top rows of keys (qwertyuiop) but, the second rows of keys ( asdfghjkl) all work except for the return key. I'v tried a commodore 64 keyboard on the Vic and all is well, ruling out bad CIA chips. i'v had the keyboard apart and cleaned all the contacts (very carefully) with no detergents at all but still, it's exactly the same. any ideas what could be wrong with it?

User avatar
mrr19121970
Vic 20 Nerd
Posts: 795
Joined: Tue Jan 19, 2016 9:22 am
Location: Germany
Occupation: IT service manager

Re: Early Vic-20 Pet style keyboard problem

Postby mrr19121970 » Sun Aug 13, 2017 10:38 pm

Did you try mixing grafite into alcohol and dipping a q-tip into this. Then apply it to the pads

User avatar
srowe
Vic 20 Afficionado
Posts: 456
Joined: Mon Jun 16, 2014 3:19 pm

Re: Early Vic-20 Pet style keyboard problem

Postby srowe » Mon Aug 14, 2017 12:15 am

Is there a pattern to the non-working keys? Check the matrix shown in "VIC Revealed" it is probably one of the column or row lines. Either the pin on the connector is corroded or a wire has fractured.

victim
Vic 20 Newbie
Posts: 2
Joined: Fri Aug 11, 2017 7:20 am
Location: UK

Re: Early Vic-20 Pet style keyboard problem

Postby victim » Mon Aug 14, 2017 3:55 am

Yes, there is a pattern of which keys work and which ones don't. As i said, i had the keyboard apart and the contacts where very clean with no dust or corrosion so it must be a problem with the block connector or a broken wire. what is the best way to clean the connector block that connects to the pins on the motherboard? i'v tried pulling & pushing it back on to try to create a clean connection but it didn't help.. i really like this PET keyboard & would love to get it working again as iv had this machine for 34 years & the C64 keyboard doesn't look or feel the same :(

User avatar
srowe
Vic 20 Afficionado
Posts: 456
Joined: Mon Jun 16, 2014 3:19 pm

Re: Early Vic-20 Pet style keyboard problem

Postby srowe » Mon Aug 14, 2017 4:52 am

If you have a multimeter then test the continuity between the connector block and the keyboard PCB. It might just be a dry joint on the PCB.


Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 1 guest